WordPress upgrade

I’ve finally had a chance to upgrade to WordPress 2.7. It’s relatively painless since I’ve switched to updating via Subversion. The only problem I hit was with text widgets. I was seeing an error along the lines of “Warning: array_keys() [function.array-keys]: The first argument should be an array in wp-includes/widgets.php on line 1044” which, if you Google it, currently appears at the top of a whole host of other people’s blogs. Deleting all (three) of my text widgets and recreating them seemed to fix the problem. It’s good to see that threaded comments have finally made it in to the base product. I’ve previously experimented with a couple of plugins but never turned them live for users as I’ve never been entirely happy with the way they’ve been implemented. (As a consequence though you’ll see that some historical posts already have threaded responses from me.) I have to say that, right now I’m not a big fan of the revamped admin pages but that may be just lack of familiarity…

Leave a Reply